Il Forum NON UFFICIALE per raccogliere le novità riguardo i Fritz!Box AVM e gli Speed tedeschi.
Per contattare l'admin: fritzboxforumitalia@gmail.com (solo per problemi di accesso)


Ai nuovi iscritti: si ricorda che è obbligatorio presentarsi nella apposita sezione, pena la cancellazione dell'account

Non sei connesso Connettiti o registrati

BrickBox Fon :cry:

Vedere l'argomento precedente Vedere l'argomento seguente Andare in basso  Messaggio [Pagina 1 di 1]

1 BrickBox Fon :cry: il Ven Ott 05, 2012 7:52 pm

mattiap


nuovo utente
nuovo utente
Come ho scritto nella presentazione mi si e' brickato il FritzBox durante un upgrade del firmware e sono qui a chiedervi consiglio.
Modello: Fritz!Box Fon annexA
Part-number: 2000-1673
Firmware pre-brick: 06.04.20
Firmware brickato: fritz.box_fon.annexa.en.06.04.49
Dal file fritzbox.export che avevo salvato subito prima dell' upgrade riporto:
FirmwareVersion=06.04.20
CONFIG_INSTALL_TYPE=ar7_4MB_2eth_2ab_isdn_pots_05804
OEM=avme
Country=99****

Le cose sono andate cosi... ho premuto il malefico pulsante del check for new firmware e il fritz si e' collegato al sito avm che ha individuato il 06.04.49 come firmware adatto.
Ho fatto il backup della configurazione di macchina.
Il fritz era sotto gruppo di continuita', cosa poteva andare storto....... ho eseguito l' upgrade via web management.

Risultato: quando si alimenta il led power lampeggia per un po' (altri led tutti spenti) poi si accende fisso (altri led sempre tutti spenti) infine dopo una manciata di secondi tutti i led fanno un lampeggio e si riparte da capo.

Cosi' a occhio direi che non riesce a partire e un watchdog lo resetta.

SSH non era abilitato.
Via telnet non ho risposta da Adam2 (da quel che ho letto con la versione che avevo a bordo era disabilitato).

Per capire se era il caso di sprecar tempo ho attaccato al volo la jtag e per lo meno il processore risponde quindi non tutto e' perduto.

Prima di andare oltre con la jtag vorrei capire se ci sono altre opzioni da poter utilizzare... che so... una scaletta da seguire passo passo in questi casi... nelle wiki non ho trovato nulla di simile.

Grazie Mattia

2 Re: BrickBox Fon :cry: il Sab Ott 06, 2012 8:25 am

Massinge


Admin
Admin
Mah non hai fatto grande danno.. io proverei con il recovery, c'è solo da capire se fare un
06.04.24 oppure un 06.04.49.
La prima cosa da valutare è quali siano le attuali variabili d'ambiente.

leggiti questo dove si parla di ftp: http://www.anime80.com/wikifritz/doku.php?id=debrand_fritz

una volta entrato in ftp sul fritz dai questi comandi:

Codice:
quote GETENV firmware_info
quote GETENV firmware_version
quote GETENV annex
quote GETENV ProductID
quote GETENV urlader
e poi riporta qui il risultato, vediamo di capirci qualcosa.
Per ora il bootloader sembra funzionare, vediamo se risvegliamo il malato.
CIao!


_________________
I miei fritz attualmente al lavoro:
Fritz box fon WLAN 7360 - fw. 111.06.21 by AVM

2 * Fritz box fon WLAN 7240 - fw. 73.05.22-Multi_annex A-B by Massinge

...e quelli a riposo:
Fritz box fon WLAN 7050
Fritz box fon wlan 7170 SL v1 29.04.87-ITA-by-Annex-massinge_b_1.02
http://www.fritzbox-forum.com

3 Re: BrickBox Fon :cry: il Mar Ott 09, 2012 5:32 pm

mattiap


nuovo utente
nuovo utente
Grazie per le dritte ma via ftp come avevo scritto non mi risponde.
Ho scaricato il programma ftp indicato nella procedura di debrand provando sia all'ip indicato nella procedura che all'ip che il malcapitato aveva prima dell' aggiornamento.

Mattia

4 Re: BrickBox Fon :cry: il Mar Ott 09, 2012 6:14 pm

mattiap


nuovo utente
nuovo utente
Non trovo nelle wiki il pinout per il cavo lan dedicato per il recovery di AVM...
Ma e' un cavo "speciale" con connessioni non standard?

Mattia

5 Re: BrickBox Fon :cry: il Mer Ott 10, 2012 5:40 am

mattiap


nuovo utente
nuovo utente
Fatto il Recovery: il vecchietto e' ripartito.

Alcune considerazioni che magari possono tornare buone anche ad altri:
1- ho usato un cavo di rete qualsiasi
2- ho provato con il recovery della versione 06.04.24 che vedeva il fritz con un bootstrap 1309 e firmware 06.04.49 (quindi l'upgrade era funzionante) ma dopo l'erase e il restoring mi dava errore durante la verifica (checking) della mtd1... WinError -4 (?????) allora ho provato con il restore della versione 06.04.24 e la procedura ha funzionato correttamente. Quindi sembra che il restore non permetta un "downgrade" ad una versione precedente...
3- ho caricato il salvataggio della configurazione pre-upgrade e allo spegnimento e riaccensione il fritz ha ripreso a resettarsi... ho pensato che magari i campi del salvataggio di un'altra versione lo avessero incasinato e ho rifatto il restore ma anche senza modificare alcun parametro della configurazione spegnendolo e riaccendendolo riprendeva a fare reset. Alla fine ho capito che deve avere per forza una adsl attiva e connessa dopo il restore se no va in banana e questo nella guida (wiki del restore) forse andrebbe segnalato.

Bene... dovrei aver detto tutto....

Adesso partiro' leggendo e verificando cosa posso fare di bello sul fritz pirat

Mattia

6 Re: BrickBox Fon :cry: Oggi a 9:43 pm

Contenuto sponsorizzato


Vedere l'argomento precedente Vedere l'argomento seguente Tornare in alto  Messaggio [Pagina 1 di 1]

Permesso di questo forum:
Non puoi rispondere agli argomenti in questo forum