Fritz!Box-Forum Italia (unofficial)
Vuoi reagire a questo messaggio? Crea un account in pochi clic o accedi per continuare.

Il Forum NON UFFICIALE per raccogliere le novità riguardo i Fritz!Box AVM e gli Speed tedeschi.
Per contattare l'admin: fritzboxforumitalia@gmail.com (solo per problemi di accesso)


Ai nuovi iscritti: si ricorda che è obbligatorio presentarsi nella apposita sezione, pena la cancellazione dell'account

Non sei connesso Connettiti o registrati

VPN con Fritz!Box 7390: The VPN server did not respond

Andare in basso  Messaggio [Pagina 1 di 1]

ctbk


nuovo utente
nuovo utente
Salve a tutti. Sto provando a configurare una VPN per accedere alla rete di casa da ovunque, ma quando provo a connettermi ottengo l'errore riportato nel titolo.

La mia conf:

Fritz!Box 7390, firmware 7.20 no brand (+Mesh interna con ripetitore)
Connessione TelecomItalia FTTC

Ho creato gli utenti e gli ho assegnato il permesso di accedere alla VPN.
Mi sono salvato le loro configurazioni e le ho impostate sia su mac che su iPhone, con entrambi mi sono messo fuori dalla rete casalinga e ho ottenuto identici risultati: timeout del server.

Il router ha un indirizzo pubblico accessibile (ne sono certo perché ho configurato un port forward verso la porta 22 di un pc interno e da "fuori" riesco a entrare senza problemi) l'indirizzo di myfritz è corretto.
Vedendo che altri avevano risolto riavviando il router, ho provato anche quello, sia da pannello che togliendo la corrente: niente da fare.

Nei log non c'è nessuna traccia.

Qualcuno ha qualche idea su dove possa essere l'errore o di un modo per indagarlo?

rohrl

rohrl
Guru
Guru
Io come te ho configurato senza problemi VPN con Mac e iPhone verso il 7590 di casa o verso l'ufficio, però l'ho fatto usando un servizio di DDNS e un IP statico.
Non so tu come abbia indicato l'indirizzo di casa nelle impostazioni della VPN, ma penso con l'indirizzo MyFritz.
Prova a dare una occhiata qui:

https://it.avm.de/assistenza/fritzbox/fritzbox-7590/banca-dati-informativa/publication/show/3448_VPN-con-FRITZ/

ctbk


nuovo utente
nuovo utente
rohrl ha scritto:Io come te ho configurato senza problemi VPN con Mac e iPhone verso il 7590 di casa o verso l'ufficio, però l'ho fatto usando un servizio di DDNS e un IP statico.
Non so tu come abbia indicato l'indirizzo di casa nelle impostazioni della VPN, ma penso con l'indirizzo MyFritz.
Prova a dare una occhiata qui:


Ho provato a usare sia l'indirizzo MyFRITZ che l'indirizzo del DDNS nelle impostazioni dei client, stesso risultato: Server did not respond.
Entrambi gli indirizzi invece funzionano senza problemi quando accedo dall'esterno alla porta del mio server che ho reso accessibile in portmapping, per questo non mi sembra un problema di IP, ma di qualcos'altro... Non so cosa però.

Può esserci qualche altra impostazione che impedisce alla VPN di "attivarsi"?

rohrl

rohrl
Guru
Guru
Secondo me è qualche impostazione sbagliata.
Il fatto che tu non riesca né con l'iPhone, né con il Mac, mi fa pensare che possa essere una impostazione nell'utente; lo hai messo vero il flag sull'abilitazione VPN dell'utente, vero?

ctbk


nuovo utente
nuovo utente
rohrl ha scritto:Secondo me è qualche impostazione sbagliata.
Il fatto che tu non riesca né con l'iPhone, né con il Mac, mi fa pensare che possa essere una impostazione nell'utente; lo hai messo vero il flag sull'abilitazione VPN dell'utente, vero?

Sì, ho due utenti, entrambi con il flag spuntato. Non capisco veramente dove può stare il problema.

C'è modo di verificare con qualche tool di rete che il router accetti (almeno in locale) connessioni alle porte necessarie per il protocollo IPSec? Comincio a pensare che ci sia qualcosa di bloccato a livello Telecom, anche se mi sembra molto strano.

rohrl

rohrl
Guru
Guru
Se è una normale linea VDSL Tim "casalinga", non mi risulta ci siano blocchi.
Prova a postare gli screenshot se vuoi

ctbk


nuovo utente
nuovo utente
rohrl ha scritto:Se è una normale linea VDSL Tim "casalinga", non mi risulta ci siano blocchi.
Prova a postare gli screenshot se vuoi

Sì è una normalissima connessione casalinga.
Non so che screenshot possano dare qualche informazione utile, ne posto alcuni dal router:
File allegati
VPN con Fritz!Box 7390: The VPN server did not respond AttachmentScreenshot 2020-09-18 at 19.37.03.png
Impostazione VPN degli utenti: attiva
Non hai il permesso di scaricare i file.
(121 kB) Scaricato 3 volte

8VPN con Fritz!Box 7390: The VPN server did not respond Empty altro screenshot il Sab Set 19, 2020 5:50 am

ctbk


nuovo utente
nuovo utente
port mapping funzionante: dall'esterno mi collego senza problemi al serverino domestico.
Non saprei che altro screenshot postare, se non quello della connessione VPN del client, ma sono tre parametri in croce (server, secret, user, pass).
File allegati
VPN con Fritz!Box 7390: The VPN server did not respond AttachmentScreenshot 2020-09-18 at 19.35.28.png
Questo portmapping dall'esterno FUNZIONA
Non hai il permesso di scaricare i file.
(95 kB) Scaricato 1 volte

rohrl

rohrl
Guru
Guru
Non si vede nulla, troppo piccolo.
Comunque controlla
- Internet, Abilitazioni, VPN. E poi le relative Impostazioni VPN.
- Sistema, Utenti FritzBox, matita sull'utente, casella VPN flaggata ed eventualmente le relative impostazioni VPN.

Magari l'errore è nel Mac o nell'iPhone ... Preferenze di Sistema, Rete, +, VPN, ...

ctbk


nuovo utente
nuovo utente
rohrl ha scritto:Non si vede nulla, troppo piccolo.
Comunque controlla
- Internet, Abilitazioni, VPN. E poi le relative Impostazioni VPN.
- Sistema, Utenti FritzBox, matita sull'utente, casella VPN flaggata ed eventualmente le relative impostazioni VPN.

Magari l'errore è nel Mac o nell'iPhone ... Preferenze di Sistema, Rete, +, VPN, ...
Mi spiace, ma più grosse di 800x600 il forum non le accettava, le immagini.

Comunque confermo: la spunta VPN è abilitata per i due utenti, se clicco sulle impostazioni VPN me le restituisce complete. Nella parte Internet->Permit Access li vedo entrambi spuntati. Le impostazioni sui client (ho provato anche con un Android) sono corrette... ma quando provo ad aprire la connessione va in timeout.

In extremis potrei provare a ripristinare il modem alle impostazioni "di fabbrica" e riconfiguarlo da capo, ma se potessi evitarlo preferirei.

Albe


nuovo utente
nuovo utente
Anche io, come scritto in altro 3d, non riesco a configurare manualmente una vpn tra mio smartphone e Fritz ma ci riesco solo tramite MyFRITZ! app.. Sono sicuro dei dati inseriti ma ciononostante continua a dirmi “connessione non riuscita”.

Credo che l’inghippo sia nella preparazione della rete locale:

“Adattare la rete IP del FRITZ!Box

Entrambi gli estremi di una connessione VPN devono utilizzare indirizzi IP di diverse reti IP. Se il il dispositivo Android è connesso a un router (ad esempio, un altro FRITZ!Box) che utilizza la stessa rete IP del proprio FRITZ!Box, non è possibile alcuna comunicazione VPN.

Nota:Tutti i FRITZ!Box utilizzano alle impostazioni di fabbrica la rete IP 192.168.178.0.

Configurare nel proprio FRITZ!Box un indirizzo IP che sia diverso dagli indirizzi IP dei router utilizzati per collegare il proprio dispositivo Android al FRITZ!Box, ad esempio 192.168.10.1 (maschera di sottorete 255.255.255.0)”

Fonte: avm:

È l’unica parte in cui sono in dubbio perché non ho voglia di toccarla, vorrebbe dire rifare tutto da capo (e proprio non mi va) ma perché con l’app invece funziona? “Tarocca” gli ip se rileva questa situazione?

rohrl

rohrl
Guru
Guru
Albe ha scritto:Anche io, come scritto in altro 3d, non riesco a configurare manualmente una vpn tra mio smartphone e Fritz ma ci riesco solo tramite MyFRITZ! app.. Sono sicuro dei dati inseriti ma ciononostante continua a dirmi “connessione non riuscita”.

Credo che l’inghippo sia nella preparazione della rete locale:

“Adattare la rete IP del FRITZ!Box

Entrambi gli estremi di una connessione VPN devono utilizzare indirizzi IP di diverse reti IP. Se il il dispositivo Android è connesso a un router (ad esempio, un altro FRITZ!Box) che utilizza la stessa rete IP del proprio FRITZ!Box, non è possibile alcuna comunicazione VPN.

Nota:Tutti i FRITZ!Box utilizzano alle impostazioni di fabbrica la rete IP 192.168.178.0.

Configurare nel proprio FRITZ!Box un indirizzo IP che sia diverso dagli indirizzi IP dei router utilizzati per collegare il proprio dispositivo Android al FRITZ!Box, ad esempio 192.168.10.1 (maschera di sottorete 255.255.255.0)”

Fonte: avm:

È l’unica parte in cui sono in dubbio perché non ho voglia di toccarla, vorrebbe dire rifare tutto da capo (e proprio non mi va) ma perché con l’app invece funziona? “Tarocca” gli ip se rileva questa situazione?
Forse hai fatto confusione, perché hai unito due tipi di istruzioni diverse.
La questione degli IP è che fra due reti VPN devono avere due classi diverse per non sovrapporsi, esempio una rete 192.168.0.0, l'altra 192.168.1.0.
Quando tu però configuri la VPN fra una rete e un singolo device (esempio uno smartphone), il problema della classe di IP non sussiste, in quanto si presume che tu ti colleghi magari quando stai usando la tua connessione dati.
Le istruzioni però prevedono anche il "caso limite", ovvero quando la rete con la VPN sia proprio la stessa della rete wifi a cui sei collegato con il device; è un caso molto remoto, che basta conoscere per evitarlo

Albe


nuovo utente
nuovo utente
Ah ok.. La guida parlava di VPN tra fritzbox e dispositivo Android..

https://it.avm.de/assistenza/vpn/consigli-e-trucchi-per-i-connessioni-con-altri-produttori/configurare-la-connessione-vpn-al-fritzbox-in-android/

beh se non è quello allora proprio non capisco dove sbaglio: ho reinserito più e più volte i dati anche provando a sostituire quello che è uno 0 con una O maiuscola della chiave.

Nulla! Ne con Fastweb, iliad o Vodafone, iOS o Android... Solo con app.

Contenuto sponsorizzato


Torna in alto  Messaggio [Pagina 1 di 1]

Permessi in questa sezione del forum:
Non puoi rispondere agli argomenti in questo forum.