Il Forum NON UFFICIALE per raccogliere le novità riguardo i Fritz!Box AVM e gli Speed tedeschi.
Per contattare l'admin: fritzboxforumitalia@gmail.com (solo per problemi di accesso)


Ai nuovi iscritti: si ricorda che è obbligatorio presentarsi nella apposita sezione, pena la cancellazione dell'account

Non sei connesso Connettiti o registrati

Problemi VoIP con CUG Eutelia e Fritz 7490

Vedere l'argomento precedente Vedere l'argomento seguente Andare in basso  Messaggio [Pagina 1 di 1]

1 Problemi VoIP con CUG Eutelia e Fritz 7490 il Dom Apr 26, 2015 4:03 am

Luxnews


nuovo utente
nuovo utente

Buongiorno a tutti, non so proprio se sia un problema solo mio, ma utilizzando i fritz di vari modelli da oltre 7 anni questa non m'era mai successa.

Allora, adesso uso un 7490 con fw originale italiano (o internazionale) 6.20.

Succedono 2 cose:
-1- con infostrada ci sono giornate nelle quali la portante cade anche 5 o 6 volte di seguito, poi magari funziona per i successivi 3 / 4 gg. Ma insomma con il 7390 stesso impianto non succedeva mai. Aperta chiamata con AVM ma da 2 mesi NADA!

-2- (oggetto del presente msg) io utilizzo la Closed User Group di Eutelia (Clauditalia Orchestra adesso) ed ha sempre funzionato alla perfezione: chiamo altri utenti dello stesso "Closed User Group" Clauditalia, utilizzando come "mittente" della chiamata un numero Clauditalia e così la chiamata Clauditalia su Clauditalia è gratuita e non serve credito.

Ebbene ultimamente il mio 7490 sembra "impallarsi" per cui questa modalità, in certe condizioni, che non riesco ad individuare, non funziona più. Unica cura: il restart del Fritz!!!!

Ho provato anche a modificare la pw del numero Clauditalia sperando che il "refresh" del numero avesse qualche effetto, ma nulla.

Il mio numero VoIP Risponde, ma solo se la chiamata arriva da altri "chiamanti"; telecom, infostrada, freevoipdeal, messagenet etc che non siano Clauditalia.

Io non posso chiamare altri utenti Clauditalia e loro passando per Clauditalia non possono chiamare me. Utilizzando altre vie però tutto funziona.
In realtà a quanto ho affermato sopra c'è un'eccezione: non posso chiamare altri utenti Clauditalia che usino il fritz, perché mio zio che utilizza il panasonic SIP (non ricordo il modello) da me stesso configurato, sono riuscito a chiamarlo proprio usando il CUG. Insomma un mistero fitto!

L'analisi dei pacchetti mediante l'Interface 0 ('internet'), ottenibile con l'utilissima funzione:

http://fritz.box/html/capture.html

rileva (dopo 5 secondi di silenzio) un

SIP/2.0 408 Request Timeout

al posto di un

SIP/2.0 180 Ringing

che invece sarebbe atteso...!

Idee?
Io penso che la 6.20 sia bella bucata almeno nella sua implementazione con il 7490.

Luca

P.S. Le altre prove le ho fatte con un 7270 ed un altro 7490: con questi la CUG non va fino al mio reboot.

Massinge


Admin
Admin
Prova con una versione firmware precedente, se prima non avevi tale problema. Oppure forse basta solamante un reset ai valori di fabbrica e reimmissione a mano della configurazione.
Ciao!


_________________
I miei fritz attualmente al lavoro:
Fritz box fon WLAN 7360 - fw. 111.06.21 by AVM

2 * Fritz box fon WLAN 7240 - fw. 73.05.22-Multi_annex A-B by Massinge

...e quelli a riposo:
Fritz box fon WLAN 7050
Fritz box fon wlan 7170 SL v1 29.04.87-ITA-by-Annex-massinge_b_1.02
http://www.fritzbox-forum.com

Luxnews


nuovo utente
nuovo utente
Grazie Massinge,
ci si rilegge eh, dopo tanti anni!

L'idea di dover reinserire tutto a mano mi sconvolge. E' un lavoro di svariate ore per ciascun Fritz, anche se sono consapevole come te, che sia una specie di panacea di molti se non tutti i mali Fritz.

Santo MessageNet, per ora uso il loro CUG e funziona, sto per partire ed al rientro tenterò di studiare meglio il problema con l'analisi dei trace eth.

Non posso tornare ad una versione precedente perché prima io utilizzavo da me un 7390 (regalato ora ad un caro amico) e dai miei un 7140 modificato con fw 7170 e tutto ha filato sempre liscio per molti anni (prima del 7390 avevo un 7270 anche lì mai 1/2 problm!)
Per carità potrei anche cercare un vecchio OS ma questo a bordo è quello di fabbrica, mi seccherebbe tornare ad un precedente magari neanche testato sul 7490. AVM appena può alza le mani al cielo e dice eh hai fatto così, ergo niente supporto!

Insomma adesso aveva funzionato "tutto" per quasi 2 mesi (salvo cadute di linea ed a volte auto-reboot del 7490), ma recentemente questa modalità (CUG) in determinate situazioni gli sembra indigesta con certa frequenza. Ipotizzo che inizi al primo occupato che si prende ed è come si cache-asse il risultato di errore e lo riproponesse (con timeout invece che con occupato).

Farò altre prove ma auspico lo stesso un FW aggiornato. il 6.20 è vecchio come il cucco (quasi 6 mesi) ed ho già notificato dei malfunzionamenti certi: hai provato ad editare delle regole?
Telephony->Call Handling-> dialing rules vai in EDIT e
sia il campo "Number range" (Telefon Number) che il "Connect via" sono vuoti. Unica soluzione è cancellare e ricreare la regola!
Lo fa su entrambi i miei 7490 (mio e dei miei) e con tutti i browser provati (vecchi e nuovi).

Mah questa AVM, ultimamente mi sta un po' deludendo.

Sono ancora in attesa si un supporto da ormai 5 mesi per un 7360 in ufficio con il routing fisso che si perde l'internet pur mantendo l'ADSL con Telecom...

Luca

P.S. Ho scoperto che nei pacchetti 432 invite come user agent mette tutti i dati dell'apparecchio:

User-Agent: AVM FRITZ!Box 7490 113.06.20 (Oct 15 2014)

interessante!

Luxnews


nuovo utente
nuovo utente
Il problema continua ma ho scoperto una specie di rimedio ant-reboot:

Allora riepilogo.

Apparentemente a seguito di qualche anomalia nella gestione del VoIP il 7490 si "incastra" quando:

  1. riceve un occupato dal numero che stiamo contattando facente parte del CUG
  2. riceve un decline es: "nternet telephony with 06xxxxxxxxx@voip.eutelia.it via voip.eutelia.it failed. Cause: Decline (603)"


In uno di quei casi, il fritz non è più in grado di chiamare qualsiasi numero eutelia (Clauditalia Orchestra).

L'unico "rimedio" era il reboot dell'apparato (il fritz 7490) che apparentemente curava il "male".

Oggi ho sperimentato un altro "rimedio": premere il nostro tasto RECONNECT che ci consente di ricevere dal provider (infostrada nel mio caso) un nuovo IP.

Quel che succede è che finalmente la sequenza SIP (degli Alcatel Eutelia) che una volta era:


  1. INVITE
  2. 100 Givng a tryi
  3. SIP/2.0 408 Request Timeout


tenta una nuova connessione con il vecchio IP!! (come non si accorgesse che l'IP è variato) ma subito dopo al tentativo seguente e con il nuovo IP diventa finalmente la sequenza corretta:


  1. INVITE
  2. 100 Givng a tryi
  3. SIP/2.0 180 Ringing
  4. etc...


Dopo di che va tutto OK

Certo non ho ancora la soluzione, ma sono sempre più convinto che dipenda dal 7490.

D'altra parte, se cambiando IP la free call allo CUG (Closed User Group) viene ripristinata ancora non mi fa comprendere (dimostrare) se il problema sia lato Registrar (eutelia) o lato del mio Fritz.

Per la cronaca, a casa dei miei ho installato da una settimana il vetusto 7140 moddato a 7170 e tutto è tornato a funzionare, e questo problema non capita più. Inoltre sono passato da circa 10 reboot a settimana a 0 !!! E sì che la linea non è il massimo, ma il 7140 è un treno, non rebootta mai a differenza del 7490.

Farlo capire a quelli dell'AVM per far loro trovare ed applicare una patch sarà il vero problema ;-)

Saluti a tutti e buona domenica.

Luca

P.S. Le funzioni di packet inspection  tel fritz (ottenibili con http://fritz.box/capture.lua + l'uso di Wireshark) sono fantastiche quando si hanno questi problemi, se solo AVM ne facesse un miglior uso!



Ultima modifica di Luxnews il Dom Mag 24, 2015 10:03 pm, modificato 1 volta (Ragione : Il titolo informa sulle modifiche nel body)

Luxnews


nuovo utente
nuovo utente
Ebbene apparentemente me la canto e me la suono.

Ho fatto molte altre verifiche e credo di aver scoperto un bug del 7490.
In pratica anche i numeri VoIP flaggati da interfaccia come DISABILITATI viceversa venivano registrati come attivi.

Poiché io ho un numero eutelia che uso in un modem in ufficio e lo stesso numero lo avevo testato sul modem di casa, proprio questa impostazione creava qualche problema ad Eutelia che si vedeva palleggiare questo numero tra le due location entrambe con pw corretta.

Insomma non appare sufficiente che il pallino di STATUS sia grigetto, ma deve essere cancellata l'entrata dal TAB "Telephone Numbers". Io per disabilitarlo ero entrato dentro al number in edit ed avevo de-flaggato in alto il segno di spunta su "Use Internet telephone number" che avrebbe dovuto rendere inattivo il numero ed infatti il "led verde" simulato dall'interfaccia era diventato grigetto ovvero (in teoria) inattivo.
Quando abilitando l'ethernet packet trace per un bel lasso di tempo, ho visto i tentativi di registrare quel numero da parte del mio modem, s'è illuminata la lampadina.

Insomma invece era attivo!

Cancellata l'entrata, per ora sembra tutto risolto ed il sistema del CUG Eutelia è tornato a funzionare!

Saluti.
Luca

Luxnews


nuovo utente
nuovo utente
Ebbene la saga continua! Nel messaggio precedente pensavo che le stranezze da me rilevate nel trace del Fritz fossero causate da lui stesso, ma mi sbagliavo.

Dopo un'attenta analisi dei file .eth estratti mediante il 7490 e letti grazie a WireShark portable, ho notato un'anomalia.

Effettivamente c'erano delle VoIP SUBSCRIBE e REGISTER sospette, apparentemente provenienti dal Fritz, ma in realtà lo User Agent non era il consueto:

AVM FRITZ!Box 7490 113.06.20 (Oct 15 2014)

bensì:

SIPAUA/0.1.001

ovvero Android. Uno delle mie varie App (presunmo CSipSimple) era la colpevole. Infatti messo lo smartphone in modalità aereo sono sparite le anomale Subscribe del numero non più resente sul Fritz.

A questo punto il problema del CUG "traballante" non sembra più sussistere, però di chi sia la colpa, con questa sequenza di scoperte e di tentativi di risoluzione, non me la sento di trovarla ed apparentemente sembra sia svanita dopo la cancellazione della vecchia entry comunque disabilitata sul Fritz anche se non sembra aver senso. L'importante è che tutto funzioni.

Certo che l'App Android CSipSimple è molto potente ma davvero difficile da imbrigliare (disabilitare) senza rimuoverla. Un vero peccato, perché consente di avere un discreto client SIP, peccato che l'interfaccia non consenta la disabilitazione e non mostri chiaramente i filtri (le redirect o divert)! Se aveste suggerimenti di client SIP su Android migliori, sono qui a disposizione!

Saluti a tutti.

Luxnews


nuovo utente
nuovo utente
Poiché il problema va e viene ANCORA, dopo innumerevoli prove e ricerche e test ed ancora si verifica solo per Clauditalia Orchestra e non per Messagenet, l'ultima mia teoria è che la colpa sia del DNS.
Infatti nel log del Fritz:

28.06.15 20:58:23 Internet telephony with 06aaaaaaaaa@voip.eutelia.it via voip.eutelia.it failed. Cause: Request Timeout (408)
28.06.15 20:57:53 Internet telephony with 06bbbbbbb@voip.eutelia.it via voip.eutelia.it failed. Cause: Request Timeout (408)
23.06.15 07:09:52 Registration of Internet telephone number 06xxxxxxxxx failed. Reason for error: DNS error
23.06.15 07:09:52 Registration of Internet telephone number zzzzz failed. Reason for error: DNS error
23.06.15 07:09:52 Registration of Internet telephone number yyyyyyyy failed. Reason for error: DNS error
23.06.15 06:53:38 Registration of Internet telephone number 06xxxxxxxxx failed. Reason for error: DNS error
23.06.15 06:53:38 Registration of Internet telephone number zzzzz failed. Reason for error: DNS error
23.06.15 06:53:38 Registration of Internet telephone number yyyyyyyy failed. Reason for error: DNS error


C'è però da notare che:


  1.    06xxxxx è Eutelia
       yyyyyy è Messagenet
       e zzzzz è FreeVoipDeal
       aaaaa e bbbb dei numeri chiamati che hanno dato errore quando non avrebbero dovuto!




E tutti gli altri funzionano, almeno apparentemente.

Insomma quel DNS error non mi convinceva ed ho eliminato il DNS di Google:

DNS servers used 8.8.8.8 (currently used for standard queries)
8.8.4.4

reimpostando quello da DHCP di infostrada:

DNS servers used

193.70.152.15 (currently used for standard queries)
212.52.97.15

Dopo pochi minuti (ogni circa 15/20 min con expire a 3600 secondi max, avviene una nuova sip:subscribe) ha ripreso a funzionare come per incanto...

Non mi spiego la cosa se non per qualche problema tra google ed i suoi filtri: nel loro DNS attuano molti sistemi di filtraggio anti-bot/malware come il temibile Cryptolocker, però come questo possa coinvolgere Clauditalia Orchestra / Eutelia, mi sembra comunque poco chiaro, ma mi sembrava utile condividere l'informazione.

Evidentemente ero l'unico a modificare il DNS di default. Per una veloce navigazione il DNS non è secondario, certo se però questo compromette il funzionamento VoIP allora meglio restare sul DHCP!

Cari saluti a tutti.

Luca



Ultima modifica di Luxnews il Lun Giu 29, 2015 5:08 pm, modificato 1 volta (Ragione : Inserito numeri VoIP reali non mascherati!)

Contenuto sponsorizzato


Vedere l'argomento precedente Vedere l'argomento seguente Tornare in alto  Messaggio [Pagina 1 di 1]

Permesso di questo forum:
Non puoi rispondere agli argomenti in questo forum