Il Forum NON UFFICIALE per raccogliere le novità riguardo i Fritz!Box AVM e gli Speed tedeschi.
Per contattare l'admin: fritzboxforumitalia@gmail.com (solo per problemi di accesso)


Ai nuovi iscritti: si ricorda che è obbligatorio presentarsi nella apposita sezione, pena la cancellazione dell'account

Non sei connesso Connettiti o registrati

problemi NAT sui firmware 6.20

Vedere l'argomento precedente Vedere l'argomento seguente Andare in basso  Messaggio [Pagina 1 di 1]

1 problemi NAT sui firmware 6.20 il Dom Gen 25, 2015 7:04 pm

firstlevel


Avanzato
Avanzato
Mi sono accorto che i firmware 6.20 hanno un problema con il firewalling. In particolare non aprono correttamente i flussi UDP.
Ho un telefono SNOM 710 nella mia rete. Succede che non riceve più l'audio.
Facendo il debug ho visto che la parte SIP è tutta OK fino ad arrivare al flusso audio. Lo SNOM manda una pacchetto per aprire la porta UDP in entrata (e quindi ricevere il flusso) ma il Fritz non apre nulla.
Questo si verifica in particolare quando l'IP audio è diverso dall'IP della segnalazione. Muto!
Per escludere problemi legati allo SNOM ho provato anche con un asterisk sempre in rete locale. Stesso risultato.
L'audio rifunziona se imposto il port forwording sul Fritz per le porte RTP.

Questo problema non ce l'ho se collego lo SNOM ad un asterisk esterno (in questo caso IP audio e IP segnalazione coincidono).

Ovviamente con un router diverso dal fritz tutto funziona normalmente.
Non so se questo comportamento è voluto o meno ma è parecchio seccante perché mi costringe a mettere mano alla configurazione del fritz ogni volta che cambio telefono voip. Prima non era così.

2 Re: problemi NAT sui firmware 6.20 il Gio Feb 05, 2015 2:23 am

nix1


nuovo utente
nuovo utente
Mi associo anch'io riscontro problemi inerenti dalla versione 6.20 e mi stupisco del fatto che tu sia uno dei primi a segnalare tale problema.

Riscontro inoltre un rumore di fondo insopportabile rispetto al firmwar precedente, spero risolvano presto.

3 Re: problemi NAT sui firmware 6.20 il Gio Feb 05, 2015 2:58 am

firstlevel


Avanzato
Avanzato
Non è stato facile diagnosticare il problema. Anche perché il Fritz non fa il trace dei flussi RTP.
Forse bisognerà attendere una nuova release.

4 Re: problemi NAT sui firmware 6.20 il Gio Feb 05, 2015 3:00 am

nix1


nuovo utente
nuovo utente
Concordo pienamente con te, ma se non scoviamo e segnaliamo noi i bug ad avm, difficilmente i poveri stagisti che sviluppano gli upgrade riusciranno ad individuare i problemi.

5 Re: problemi NAT sui firmware 6.20 il Gio Feb 05, 2015 6:28 am

Massinge


Admin
Admin
@Tutti: utilizzate il QUOTE solo quando è necessario!


_________________
I miei fritz attualmente al lavoro:
Fritz box fon WLAN 7360 - fw. 111.06.21 by AVM

2 * Fritz box fon WLAN 7240 - fw. 73.05.22-Multi_annex A-B by Massinge

...e quelli a riposo:
Fritz box fon WLAN 7050
Fritz box fon wlan 7170 SL v1 29.04.87-ITA-by-Annex-massinge_b_1.02
http://www.fritzbox-forum.com

6 Re: problemi NAT sui firmware 6.20 il Gio Feb 26, 2015 5:41 am

Raid085


nuovo utente
nuovo utente
firstlevel ha scritto:Mi sono accorto che i firmware 6.20 hanno un problema con il firewalling. In particolare non aprono correttamente i flussi UDP.
Ho un telefono SNOM 710 nella mia rete. Succede che non riceve più l'audio.
Facendo il debug ho visto che la parte SIP è tutta OK fino ad arrivare al flusso audio. Lo SNOM manda una pacchetto per aprire la porta UDP in entrata (e quindi ricevere il flusso) ma il Fritz non apre nulla.
Questo si verifica in particolare quando l'IP audio è diverso dall'IP della segnalazione. Muto!
Per escludere problemi legati allo SNOM ho provato anche con un asterisk sempre in rete locale. Stesso risultato.
L'audio rifunziona se imposto il port forwording sul Fritz per le porte RTP.

Questo problema non ce l'ho se collego lo SNOM ad un asterisk esterno (in questo caso IP audio e IP segnalazione coincidono).

Ovviamente con un router diverso dal fritz tutto funziona normalmente.
Non so se questo comportamento è voluto o meno ma è parecchio seccante perché mi costringe a mettere mano alla configurazione del fritz ogni volta che cambio telefono voip. Prima non era così.


Ciao firstlevel! Hai poi risolto??

7 Re: problemi NAT sui firmware 6.20 il Gio Feb 26, 2015 6:38 am

firstlevel


Avanzato
Avanzato
Raid085 ha scritto:Ciao firstlevel! Hai poi risolto??
In realtà. L'unica soluzione è aprire le porte UDP in modo da far passare il traffico RTP. Dai test che ho fatto il nuovo firmware si apre solo quando passando entrambi i pacchetti CLASSIC-STUN (request e response). Se il peer non manda il response come nel mio caso (il peer è ul 7270) il firewall non si apre.

Contenuto sponsorizzato


Vedere l'argomento precedente Vedere l'argomento seguente Tornare in alto  Messaggio [Pagina 1 di 1]

Permesso di questo forum:
Non puoi rispondere agli argomenti in questo forum