Il Forum NON UFFICIALE per raccogliere le novità riguardo i Fritz!Box AVM e gli Speed tedeschi.
Per contattare l'admin: fritzboxforumitalia@gmail.com (solo per problemi di accesso)


Ai nuovi iscritti: si ricorda che è obbligatorio presentarsi nella apposita sezione, pena la cancellazione dell'account

Non sei connesso Connettiti o registrati

Scompattare firmware derivati da Speed-to-fritz con freetz - problema loop

Vedere l'argomento precedente Vedere l'argomento seguente Andare in basso  Messaggio [Pagina 1 di 1]

Flane


moderatore
moderatore
Sono incappato in un problema che non mi era mai capitato.

Ho necessità di scompattare un firmware ricavato mediante speed-to-fritz per sostituire il solo driver dsl.
Premetto che tale firmware funziona regolarmente se caricato sullo speedport.

Procedo come segue:
- Scompatto il firmware con freetz mediante il solito comando ./fwmod -u
- cambio il file del driver DLS
- ricompatto il firmware con freetz mediante il solito comando ./fwmod -p
- carico il firmware sullo speedport (che già montava regolarmente il firmware prima della modifica) con ftp-uploader
- lo speedport mi và in loop e continua a riavviarsi  Crying or Very sad 

Ho provato la procedura con freetz 1.1.3 e 1.2 e sempre lo stesso problema.

Qualcuno ha idea di cosa possa essere la causa?
Sinceramente ho eseguito questa procedura una infinità di volte con i firmware per il W900V, ma ora con il W503V ho questo problema  Crying or Very sad Crying or Very sad 

confido fiducioso in un vostro aiuto ....  Wink

http://www.flanesi.it

Naf


Admin
Admin
Semplicemente perché stai caricando un modulo dsp_ur8 di un kernel 2.6.32.21 in un firmware con kernel 2.6.19.2, dopo le prove che ho fatto oggi sono giunto a questa conclusione e se vuoi, prove a simulare lo stesso firmware -u senza cambiare niente e fai -p per poi caricarlo nel speedport per vedere il risultato.
L'unica cosa che volevo provare nei prossimi giorni e di usare la modalità exchange kernel nello sp2f per vedere come si comporta.


_________________
Archlinux
Fritz!Fon 7150 WLAN fw 38.04.71-Ita Naf-Mod
Fritz!Box Fon WLAN 7240 fw 73.05.54.de_en_es_fr_it-Naf-Mod
Speedport W 503V Typ A fw 54-04-89 Multi-de_en_es_fr_it Naf-Mod
Speedport W 920V fw 75-04-92 Multi-de_en_es_fr_it Naf-Mod
Fritz!Box Fon WLAN 7330_SL fw 116.06.30.de_en_es_fr_it-Naf-Mod

Flane


moderatore
moderatore
azz.. effettivamente potrebbe essere, in quanto altre operazioni di modifica le ho fatte senza problemi.

Che cosa dovrebbe fare la modalità exchange kernel di sp2f ?


_________________
Ecco con lo Speedport W503V e la mia Alice 20Mb cosa si riesce a fare:
http://www.flanesi.it

Naf


Admin
Admin
In teoria dovrebbe sostituirlo ma non lo mai provato per cui non so se funziona e cmq appena ho un po di tempo lo provo.


_________________
Archlinux
Fritz!Fon 7150 WLAN fw 38.04.71-Ita Naf-Mod
Fritz!Box Fon WLAN 7240 fw 73.05.54.de_en_es_fr_it-Naf-Mod
Speedport W 503V Typ A fw 54-04-89 Multi-de_en_es_fr_it Naf-Mod
Speedport W 920V fw 75-04-92 Multi-de_en_es_fr_it Naf-Mod
Fritz!Box Fon WLAN 7330_SL fw 116.06.30.de_en_es_fr_it-Naf-Mod

Flane


moderatore
moderatore
Ho trovato qualche minuto di tempo per fare il semplice test di prendere il firmware, scompattarlo e ricompattarlo tramite fwmod di freetz, senza fare nessuna modifica.

Anche in questo caso aggiornando il W503V con il nuovo firmware, il sistema va in loop con contiunui riavvi.

Quindi il problema non è del driver DSL ma di freetz che nella scompattazione combina qualche problema.....

Poi ho notato un'altro problema:
-se provo ad aggiornare da interfaccia WEB il sistema non si aggiorna. Il W503V continua a rimanere in aggiornamento con i led lampeggianti in sequenza ed anche la pagine web rimane in aggiornamento. (l'ho lasciato per 15 min). Negli aggiornamenti sopra ho sempre usato ftpuploader.

Mio è venuto il dubbio che sia successo qualche casino nella prima modifica che avevo fatto al firmware tramite scompattazione e che ora me la stia portanto dietro ....


_________________
Ecco con lo Speedport W503V e la mia Alice 20Mb cosa si riesce a fare:
http://www.flanesi.it

Massinge


Admin
Admin
hai cancellato anche mtd3 e 4?


_________________
I miei fritz attualmente al lavoro:
Fritz box fon WLAN 7360 - fw. 111.06.21 by AVM

2 * Fritz box fon WLAN 7240 - fw. 73.05.22-Multi_annex A-B by Massinge

...e quelli a riposo:
Fritz box fon WLAN 7050
Fritz box fon wlan 7170 SL v1 29.04.87-ITA-by-Annex-massinge_b_1.02
http://www.fritzbox-forum.com

Flane


moderatore
moderatore
Ho provato si cancellando mtd3 e 4 che non.
Il risultato è sempre lo stesso ...... fritz in loop  Crying or Very sad 


_________________
Ecco con lo Speedport W503V e la mia Alice 20Mb cosa si riesce a fare:
http://www.flanesi.it

Massinge


Admin
Admin
Purtroppo dipende dalla compilazione che mette in opera freetz: l'unico consiglio che posso darti è ricrearti da zero freetz (il programma).
Ciao!


_________________
I miei fritz attualmente al lavoro:
Fritz box fon WLAN 7360 - fw. 111.06.21 by AVM

2 * Fritz box fon WLAN 7240 - fw. 73.05.22-Multi_annex A-B by Massinge

...e quelli a riposo:
Fritz box fon WLAN 7050
Fritz box fon wlan 7170 SL v1 29.04.87-ITA-by-Annex-massinge_b_1.02
http://www.fritzbox-forum.com

Flane


moderatore
moderatore
Continuo in altra discussione in quanto trattandosi di problemi legati allo Speedport W503V ne discutiamo nella sezione corretta


_________________
Ecco con lo Speedport W503V e la mia Alice 20Mb cosa si riesce a fare:
http://www.flanesi.it

Contenuto sponsorizzato


Vedere l'argomento precedente Vedere l'argomento seguente Tornare in alto  Messaggio [Pagina 1 di 1]

Permesso di questo forum:
Non puoi rispondere agli argomenti in questo forum